Actions

Difference between revisions of "System Administrator's Guide/Granting Trigger Privilege"

From Mahara Wiki

< System Administrator's Guide
(Created page with "If your Mahara database user does not have permission to create triggers on the database, you will need to explicitly grant the trigger privilege to the user. To do this, issue …")
 
Line 6: Line 6:
  
 
If you don't have access to the terminal client, but created the database user using some external tool like 'mysql administrator', you should be able to edit the user's permissions using the same tool.  Make sure the TRIGGER privilege is granted.
 
If you don't have access to the terminal client, but created the database user using some external tool like 'mysql administrator', you should be able to edit the user's permissions using the same tool.  Make sure the TRIGGER privilege is granted.
 +
 +
If you have granted trigger privileges to the appropriate user, but you are still having trouble upgrading or installing, the following post and bug report may be helpful:
 +
* https://mahara.org/interaction/forum/topic.php?id=4516#post20155
 +
* http://bugs.mysql.com/bug.php?id=39489

Revision as of 16:24, 23 May 2012

If your Mahara database user does not have permission to create triggers on the database, you will need to explicitly grant the trigger privilege to the user. To do this, issue the following command in your MySQL client:

 GRANT TRIGGER ON <mahara_db_name>.* TO '<mahara_db_user>'@'localhost';

Replace <mahara_db_name> with the name of your Mahara database, and <mahara_db_user> with the database user. You can find these values in your config.php file, under $cfg->dbname and $cfg->dbuser.

If you don't have access to the terminal client, but created the database user using some external tool like 'mysql administrator', you should be able to edit the user's permissions using the same tool. Make sure the TRIGGER privilege is granted.

If you have granted trigger privileges to the appropriate user, but you are still having trouble upgrading or installing, the following post and bug report may be helpful: